Partial API Outage
Incident Report for Xero Ltd - API
Resolved
This incident has been resolved.
Posted Nov 04, 2019 - 23:04 NZDT
Monitoring
We believe the root cause has been addressed, we will continue monitoring the situation. Thank you for your patience.
Posted Nov 04, 2019 - 22:40 NZDT
Update
With additional load coming online we're seeing a spike in latency and a small percentage calls are failing. The team is still getting to the bottom of things.
Posted Nov 04, 2019 - 22:12 NZDT
Update
Latency is still low so we're setting this as only "Degraded Performance" in the meanwhile.
Posted Nov 04, 2019 - 20:24 NZDT
Update
Although the latency seems to have dropped back down to normal levels, we're still working to identify and correct the root cause of the problem. We will keep you updated.
Posted Nov 04, 2019 - 19:22 NZDT
Update
We’re closer to getting the affected users back on Xero, sorry for the disruption this is causing you.
Posted Nov 04, 2019 - 18:07 NZDT
Identified
Our Product Team have identified the cause, and are working to restore access for the affected users as soon as possible.
Posted Nov 04, 2019 - 17:02 NZDT
Investigating
Sadly the API is partially unavailable again. Our apologies for this, the team are investigating and trying to identify the root cause.
Posted Nov 04, 2019 - 16:17 NZDT
This incident affected: Xero APIs (Accounting API, Files API, Payroll API, Bankfeeds API, Xero HQ API, Assets API, Signup API).