Apps may have problems using refresh tokens
Incident Report for Xero Ltd - API
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 13:46 NZST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2022 - 12:17 NZST
Identified
The issue has been identified and a fix is being implemented
Posted Jun 09, 2022 - 09:39 NZST
Update
We are continuing to investigate this issue.
Re-authorising connections and using the new refresh token in refreshes is still the suggested workaround.
Apologies for the inconvenience caused.
Posted Jun 09, 2022 - 02:51 NZST
Update
Apps may still have trouble using refresh tokens. Affected users can re-authorise apps to workaround this issue. We are still working towards a resolution. We apologise for the disruption.
Posted Jun 08, 2022 - 20:05 NZST
Update
Apps may still encounter issues using refresh tokens. We are continuing to investigate.
Posted Jun 08, 2022 - 18:46 NZST
Update
Some apps may have problems using refresh tokens. We are continuing to investigate.
Posted Jun 08, 2022 - 17:53 NZST
Investigating
We are currently investigating this issue.
Posted Jun 08, 2022 - 17:20 NZST
This incident affected: Xero APIs (Accounting API, Files API, Payroll API, Bankfeeds API, Xero HQ API, Assets API, Xero Practice Manager API).