UK> Payroll > Some customers may have encountered SDK errors

Incident Report for Xero Ltd - API

Resolved

Our team has resolved the issue where UK customers experienced errors attempting to add the Leave Type of Statutory Neonatal Care Pay. This was caused by a release which caused customers to experience SDK errors. We apologise for any inconvenience.
Posted Apr 10, 2025 - 18:31 NZST

Monitoring

The SDKs have now been updated, we would advise any apps that use the UK Payroll API to update to the latest version as soon as possible. https://developer.xero.com/documentation/sdks-and-tools/libraries/overview/.

Status Last Reviewed: 15:51 UTC
Posted Apr 08, 2025 - 03:51 NZST

Identified

We are adding support for a new form of Leave Type(LeaveType) in UK Payroll called Statutory Neonatal Care Pay (StatutoryNeonatalCarePay). This was released earlier this week but not within the public SDKs which may have caused some customers to encounter SDK errors. We have temporarily rolled back the release whilst we work to update the SDKs as a matter of urgency.

Status Last Reviewed: 16:50 UTC
Posted Apr 05, 2025 - 05:52 NZDT