Our team has resolved the issue impacting a user attempts to authorise an app connection. This was caused by a recent release and has now been rolled back by our product team.
Any users that were unable to connect prior to the resolution should now be able to connect. If they are still experiencing issues we would ask you to advise them to:
Navigate to the Settings > Connected apps screen within Xero Locate your app Click the disconnect button
They should then re-attempt the connection process from within your interface.
We apologise for any inconvenience caused.
Posted Aug 01, 2025 - 03:49 NZST
Investigating
We are currently investigating an issue with the AuthEventId that is returned when using the Connections endpoint. Apps may encounter issues when a user attempts to authorise an app connection.
Posted Aug 01, 2025 - 01:17 NZST
This incident affected: Xero APIs (Accounting API).