Global: We are aware of an issue preventing some connections to Xero’s Public APIs

Incident Report for Xero Ltd - API

Resolved

Our team has resolved the issue impacting customers connecting to Xero’s Public APIs.

This related to an issue affecting our third party supplier, Amazon Web Services (AWS).

This issue has now been resolved. We thank customers for their patience during this time.
Posted Oct 21, 2025 - 00:56 NZDT

Monitoring

Some customers are now successfully connecting to Xero’s Public APIs. AWS has reported recovery across most of their impacted services. We thank customers for their patience.

Status Last Reviewed: 11.36am UTC
Posted Oct 20, 2025 - 23:09 NZDT

Identified

We’re aware of an issue preventing some connections to Xero’s Public APIs. This is related to an issue with our third-party provider, Amazon Web Services (AWS), who are investigating with urgency.

Status Last Reviewed: 9.38am UTC
Posted Oct 20, 2025 - 21:57 NZDT
This incident affected: Xero APIs (Accounting API, Files API, Payroll API, Bankfeeds API, Xero HQ API, Assets API, Xero Practice Manager API) and Developer tools & services (Developer Centre, Feedback Forum, App Centre, Webhooks).