Our technical teams have observed a return of normal services and we're monitoring for any remaining impact. We'll continue to monitor this issue for our customers, and want to thank you for your patience during this time.
Status Last Reviewed: 5:09 UTC
Posted Oct 21, 2025 - 18:10 NZDT
Update
We are continuing to work on resolving the impacts of the AWS issue, and some customers are successfully connecting with Xero APIs. We are monitoring the results. Customers may still experience general slowness and errors. We appreciate your ongoing patience during this time.
Status Last Reviewed: 2:44 UTC
Posted Oct 21, 2025 - 09:57 NZDT
Investigating
Some customers continue to experience slowness and issues when accessing the API with Xero due to an global issue with Amazon Web Services (AWS).
AWS is a Xero third-party provider, and are working to rectify with urgency. Some customers can successfully login to Xero and we are monitoring.