Global: Webhook delivery issues

Incident Report for Xero Ltd - API

Resolved

Our team has resolved the issue causing some customers to have delayed or doubled Webhook deliveries. We apologise for any inconvenience caused.
Posted Jun 03, 2025 - 02:20 NZST

Investigating

We are aware that some customers might be getting delayed or doubled Webhook deliveries. We are investigating this with urgency.
Posted Jun 03, 2025 - 01:10 NZST
This incident affected: Xero APIs (Accounting API, Files API, Payroll API, Bankfeeds API, Xero HQ API, Assets API, Xero Practice Manager API).