Global: API Webhooks - API users not receiving webhooks

Incident Report for Xero Ltd - API

Resolved

Our team has resolved the issue impacting global API users trying to retrieve webhooks. We apologise for any inconvenience this has caused.

This was caused by network instability and we've since restored service
Posted Jul 08, 2025 - 12:19 NZST

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 11:38pm UTC
Posted Jul 08, 2025 - 11:38 NZST

Identified

We have identified what is preventing global API users trying to receive webhooks. We understand that as a result you will not receive notifications of updates.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 11:32pm UTC
Posted Jul 08, 2025 - 11:33 NZST
This incident affected: Developer tools & services (Webhooks).