Users experiencing various issues when authorising, connecting or managing an API app or integration
Incident Report for Xero Ltd - API
Resolved
All services have now returned to normal. Please get in touch with our support team should you still be experiencing any issues.
Sorry for any inconvenience the outage will have caused.
Posted Dec 23, 2021 - 05:09 NZDT
Update
We are continuing to see service returning to normal. However our webhooks will continue to experience some delays as we deliver the backlogged events. Thank you once again for patience whilst this has been investigated.
Posted Dec 23, 2021 - 04:12 NZDT
Monitoring
AWS are currently in the process of restoring services and we are seeing improvements. Thank you for your patience whilst we continue to monitor the issue.
Posted Dec 23, 2021 - 03:02 NZDT
Identified
The issue appears to be related to a wider AWS outage. We are currently working with them to further investigate the issue.
Posted Dec 23, 2021 - 01:56 NZDT
Investigating
We are currently investigating an issue when users attempt to connect an API app or integration.
Posted Dec 23, 2021 - 01:35 NZDT
This incident affected: Xero APIs (Accounting API, Files API, Payroll API, Bankfeeds API, Xero HQ API, Assets API, Xero Practice Manager API), Developer tools & services (Developer Centre, Feedback Forum, App Centre, Webhooks), and WorkflowMax (WorkflowMax API).