Users are unable to access Xero
Incident Report for Xero Ltd - API
Resolved
We can confirm that the issue we have been experiencing has now been resolved and service has resumed. The issue was related to our login infrastructure, and was not a security incident. A tool used to store and trigger events in the login flow was not operating as expected and resulted in failures and errors. Our product teams worked to restore the flow of these events, and return service in a controlled way. Once again, we apologise for the inconvenience this has caused our customers.
Posted Jul 28, 2021 - 07:07 NZST
Monitoring
Our teams working on this issue have implemented a fix and we are seeing service return to normal. We will continue to monitor this closely.
Posted Jul 28, 2021 - 04:45 NZST
Update
We are continuing to investigate and work through this issue. Thanks for your patience.
Posted Jul 28, 2021 - 03:00 NZST
Update
Thanks for your patience, our Product Team are doing everything they can to get you back online.

Please note, that passwords and logins are not incorrect. There is no need to attempt to reset your password.
Posted Jul 27, 2021 - 22:51 NZST
Update
We are continuing to investigate this issue - as soon as we have any further information we'll be sure to let you know.
Posted Jul 27, 2021 - 22:08 NZST
Investigating
We’re currently aware of an issue preventing access to Xero. For our API Users, this means no new connections can currently be made. Our Product Team is investigating this with urgency.
Posted Jul 27, 2021 - 21:57 NZST
This incident affected: Developer tools & services (Developer Centre) and Xero APIs (Accounting API, Files API, Payroll API, Bankfeeds API, Xero HQ API, Assets API, Xero Practice Manager API).