Global: API - some customers may be experiencing an issue using the API due to a current issue with Xero.

Incident Report for Xero Ltd - API

Update

We are continuing to monitor for any further issues.
Posted May 11, 2026 - 15:23 NZST

Monitoring

Our team has resolved the issue impacting customers. Xero is now stable and customers should be able to use the platform normally. Our engineering teams will continue to monitor closely to ensure everything remains on track.

We apologise for any inconvenience this has caused and appreciate your patience during this time.
Posted May 11, 2026 - 12:36 NZST

Update

We're seeing recovery of our systems, and are continuing to investigate this issue.
Posted May 11, 2026 - 12:07 NZST

Investigating

We are aware our API customers trying to integrate or use the Xero API are experiencing issues. Our team is investigating this with urgency.
Posted May 11, 2026 - 11:57 NZST
This incident affects: Xero APIs (Accounting API, Files API, Payroll API, Bankfeeds API, Xero HQ API, Assets API, Xero Practice Manager API).