General API services impacts
Incident Report for Xero Ltd - API
Resolved
This incident has been resolved.
Posted Nov 28, 2020 - 08:07 NZDT
Update
We have made some optimisations to the Webhooks system. You may notice an increase in throughput as we work through the backlog. Thank you for your continued patience.
Posted Nov 27, 2020 - 12:39 NZDT
Update
We are still monitoring the delay on Webhooks, but all other services have returned to normal. We'll keep you updated.
Posted Nov 26, 2020 - 23:30 NZDT
Monitoring
We're starting to see services returning to normal although Webhooks are still delayed and will continue to be for the next few hours. We will continue monitoring the situation.
Posted Nov 26, 2020 - 19:24 NZDT
Update
While we're seeing small improvements to services, it isn't enough for us to close this incident off. Webhooks are still delayed and will take several hours to return to normal. Thank you for your patience today
Posted Nov 26, 2020 - 16:44 NZDT
Update
Unfortunately we have no new updates from AWS regarding an exact time that services will return to normal. We will let you know once we see an improvement on our end.
Posted Nov 26, 2020 - 13:15 NZDT
Update
AWS have issued a new status update stating that they expect a full recovery to take a few hours. Once we see an improvement in our metrics, we'll make another update.
Posted Nov 26, 2020 - 09:23 NZDT
Update
We're now also seeing problems with users trying to view their API logs on developer.xero.com, we're continuing to monitor the AWS outage
Posted Nov 26, 2020 - 08:42 NZDT
Update
We are continuing to work on a fix for this issue.
Posted Nov 26, 2020 - 08:09 NZDT
Identified
Our services are currently being impacted by Multiple AWS service outages (https://status.aws.amazon.com/). We're failing to authorise new API Connections, the OAuth 1 API Gateway is currently unstable due to these AWS problems, Webhooks are currently delayed and the Contact Support forms are also unavailable due to these problems.

We apologise for the inconvenience, we are monitoring the problems with AWS closely and working to get everything back up and running as soon as we can.
Posted Nov 26, 2020 - 08:07 NZDT
Investigating
We are currently investigating this issue.
Posted Nov 26, 2020 - 07:44 NZDT
This incident affected: Xero APIs (Accounting API, Files API, Payroll API, Bankfeeds API, Xero HQ API, Assets API, Xero Practice Manager API) and Developer tools & services (Webhooks).