Global: Xero Files - Issues accessing files

Incident Report for Xero Ltd - API

Resolved

This was caused by a product release, which has been rolled back to resolve customer impact. We apologise for any inconvenience caused.
Posted Feb 19, 2025 - 01:46 NZDT

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12:04 UTC.
Posted Feb 19, 2025 - 01:04 NZDT

Investigating

We are aware that some customers trying to use Xero Files are experiencing errors or poor performance. This relates to Xero features that uses files including (but not limited to) expenses, Workpapers, emailing invoices and downloading bills. Our team is investigating this with urgency.
Posted Feb 19, 2025 - 00:24 NZDT
This incident affected: Xero APIs (Files API).