Degraded Performance on Xero API
Incident Report for Xero Ltd - API
Resolved
This incident has now been resolved. Thank you for your patience.
Posted Nov 04, 2019 - 15:03 NZDT
Update
The latency seems stable since the last fix went into production, we will continue monitoring.
Posted Nov 04, 2019 - 14:53 NZDT
Update
We're moving this back to "Degraded Performance" now that things have stabilized. We are still seeing problems with latency occasionally increasing.
Posted Nov 04, 2019 - 14:06 NZDT
Update
We're seeing the latency on the API spike once again, our apologies for the inconvenience caused. We have upgraded the status of the incident from "Degraded Performance" to "Partial Outage" based on the number of errors we're seeing.
Posted Nov 04, 2019 - 13:53 NZDT
Update
We're still monitoring the situation and seeing periodic spikes in latency.
Posted Nov 04, 2019 - 12:56 NZDT
Monitoring
The latency is back down, we're continuing to monitor the situation.
Posted Nov 04, 2019 - 11:55 NZDT
Identified
We're noticing an increased latency on the API, the team is currently working on this.
Posted Nov 04, 2019 - 11:43 NZDT
This incident affected: Xero APIs (Accounting API, Files API, Payroll API, Bankfeeds API, Xero HQ API, Assets API, Signup API).