A high level of 500 errors affecting all APIs
Incident Report for Xero Ltd - API
Resolved
This incident has been resolved. Apologies for the disruption.
Posted 6 months ago. Mar 13, 2019 - 11:50 NZDT
Monitoring
The fix has now been deployed to all instances. Regular service has been restored. Continuing to monitor.
Posted 6 months ago. Mar 13, 2019 - 11:31 NZDT
Identified
The problem is only affecting certain instances of our API gateway so requests may seemingly 500 at random. Currently cycling through a fix. Will be resolved shortly.
Posted 6 months ago. Mar 13, 2019 - 11:15 NZDT
Investigating
Investigating now
Posted 6 months ago. Mar 13, 2019 - 11:08 NZDT
This incident affected: Xero APIs (Accounting API, Files API, Payroll API, Bankfeeds API, Xero HQ API, Assets API, Signup API).