Xero Identity Outage
Incident Report for Xero Ltd - API
Resolved
This incident has been resolved. Apologies for the disruption.

Xero Identity, the Xero API and the developer portal are all fully operational.
Posted Jun 17, 2021 - 10:47 NZST
Monitoring
A fix has been implemented and performance has recovered to normal levels.

The outage caused intermittent 504 errors when issuing access tokens from Xero Identity.

The impact was that successful token requests were about 50% of normal levels from 8:10am - 9:45am NZT.
Posted Jun 17, 2021 - 10:15 NZST
Identified
The issues has been identified and Xero Identity is recovering
Posted Jun 17, 2021 - 09:57 NZST
Investigating
Currently investigating issues with Xero Identity. This well affect refreshing access tokens, authorising new connections and logging in to the developer portal.
Posted Jun 17, 2021 - 08:45 NZST
This incident affected: Xero APIs (Accounting API, Files API, Payroll API, Bankfeeds API, Xero HQ API, Assets API, Xero Practice Manager API), Developer tools & services (Developer Centre, Feedback Forum, App Centre, Webhooks), and WorkflowMax (WorkflowMax API).